Index  •  FAQ  •  Search  

It is currently Fri Sep 22, 2017 8:11 pm

This is a static archive the Twin Cities Carry forum, maintained as a public service by the current forum of record, The Minnesota Carry Forum.

All times are UTC - 6 hours




Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 2 posts ] 
 HSM ammo issues with Glock 17 9mm 
Author Message
 Post subject: HSM ammo issues with Glock 17 9mm
PostPosted: Tue Apr 28, 2009 8:11 pm 
Member
User avatar

Joined: Mon Mar 02, 2009 8:23 pm
Posts: 48
Location: North Metro
Sorry for the long post in advance.

I purchased 10 boxes of HSM reload ammo in 9mm Luger 115gr, FMJ "police ammunition". I shot 4 boxes of the HSM's through my G17 with no issues. (The G17 has also shot hundreds of boxes of Winchester white box and American Eagle with no issues) I don't feel it's a Glock thing. :)

It seems one of my ten boxes of HSM's was loaded on a Friday @ 3:30pm.
I don't know how to properly define the issue the HSM's were causing, here it goes...

Bang, Bang, Bang, Bang, Bang, Bang, Click.

The rounds properly ejected, however the round that did not fire wasn't fully seated into the barrel, holding the slide slightly open (1/16") in the rear ward position. I manually closed the slide. It did not take any force to close the slide, just a touch of a finger. After the slide was back in firing possition; the round fired and ejected normally.

This occurred 3 times in one box of 50 Rounds.

I checked my barrel and recoil spring for any issues and none were found. I did notice that some of the HSM's looked to have an odd crimp, not factory. Also some of the reloads have a visible "crease" mid way down the casing. The crease can not be felt or measured, just seen.

Now paranoid, I shot a box of 50 American eagles with no issues.

So, has anyone experienced this? I think is is an HSM crimping, height issue?????

Thanks!


Offline
 Profile  
 
 Post subject:
PostPosted: Wed Apr 29, 2009 11:08 am 
Journeyman Member
User avatar

Joined: Sun Jul 27, 2008 2:36 pm
Posts: 67
Location: Apple Valley, MN
Hmmm.... can you provide any more info about the rounds themselves?

As you are shooting reloads, there are a lot of variables at hand.

Maybe the cases weren't properly resized. I was loading my own 7.5x55 rounds for my Swiss K31 that would not chamber, although my dummy rounds did. It turns out that the cases weren't sized correctly, and the shoulder was too large to fit into the chamber completely. The dummy round was used many times, so I was form-fitting the case myself when I was chambering the round.

Maybe the length of the cartridge (OAL) is too long. That might explain why the slide wouldn't close.


Offline
 Profile  
 
Display posts from previous:  Sort by  
Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 2 posts ] 

This is a static archive the Twin Cities Carry forum, maintained as a public service by the current forum of record, The Minnesota Carry Forum.

All times are UTC - 6 hours


 Who is online 

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron


 
Index  |  FAQ  |  Search

phpBB © 2000, 2002, 2005, 2007 phpBB Group